Введение

 Top Next

Программный комплекс TimeControl может быть интегрирован с различными управленчискими системами. Интеграция осуществляется на основе DLL (Dinamic Link Library) TimeControlSDK.dll.


Типы данных

 Top Previous Next

TStr8 = Array[0..7] of AnsiChar;

TStr20 = Array[0..19] of AnsiChar;

TStr64 = Array[0..63] of AnsiChar;

TStr128 = Array[0..127] of AnsiChar;

TStr16 = Array[0..15] of AnsiChar;

TStr48 = Array[0..47] of AnsiChar;

//информация о сотруднике

TPersonInfo = packed record

TabNum : TStr8; //табельный номер

FirsrName : TStr64; //Фамилия сотрудника

LastName : TStr64; //Имя сотрудника

MidName : TStr64; //Отчество сотрудника

FullName : TStr128; //Полное имя сотрудника ФИО

DepartCode : TStr8; //Код подразделения

PostCode : TStr8; //Код должности

GroupCode : TStr8; //Код группы пользователей

Sex : Integer; //Пол 0 - не задан 1 - Мужской 2 - Женский

IsUser : Integer; //1 - сотрудник является пользователем 0 - не является пользователем

UserPassword : TStr20; //пароль доступа в систему

CardCode : TStr20; //текстовый код магнитной (бесконтактной) карты

EnterPassword : TStr20; //пароль доступа для устройств

DontUseControl : Integer; //1 - не использовать сотрудника для учета

TimeProfileCode : TStr8; //код профиля учета рабочего времени

EnterProfileCode : TStr8; //код профиля доступа

IsLocked : Integer; //0 - сотрудник работает 1 - сотрудник уволен

LockDate : TStr16; //дата увольнения сотрудника

LockReasonCode : TStr8; //код причины увольнения

Phone : TStr20; //телефон сотрудника

MobPhone : TStr20; //мобильный телефон

WorkPhone : TStr20; //рабочий телефон

Mail : TStr48; //электронный адрес

end;


Возвращаемые значения

TResult = Integer;

TResult принимает следующие значения:

0 - удачное выполнение операции, > 0 код ошибки из следующей таблицы:

Значение | Идентификатор | Описание
1 | ERROR_ALREADY_CONNECT | Подключение к базе данных уже установлено.
2 | ERROR_NOT_REGISTRATE | Программный комплекс не зарегистрирован на данном компьютере.
3 | ERROR_NOT_ALLOW_REGISTRATE | Лицензия не позволяет использовать операцию на данном компьютере.
4 | ERROR_CONNECT | Ошибка подключения к базе данных.
5 | ERROR_CONNECT_NOT_PRESENT | Не установлено подключение к базе данных.
6 | ERROR_LOST_CONNECT | Потеря связи с базой данных.
7 | ERROR_USER_NOT_FOUND | Пользователь с таб. номером не найден, либо запрещен вход в систему.
8 | ERROR_PASSWORD | Не верный пароль.
9 | ERROR_NOT_LOGIN | Пользователь не вошел в систему.
10 | ERROR_NOT_RIGHTS | Операция запрещена для данного пользователя.
11 | ERROR_PERSON_NOT_FOUND | Сотрудник с табельным номером не найден.
12 | ERROR_PARAM_VALUE | Ошибка в значениях входящих параметров.
13 | ERROR_DEVICE_CONNECT | Ошибка подключения к серверу устройсв.


AddEditPersonInfo

Добавление(редактирование сотрудника).

Если сотрудник с табельным номером ApersonInfo.TabNum присутствует в базе данных, то информация будет обновлена. Иначе будет добавлен новый сотрудник.

function AddEditPersonInfo(const APersonInfo: TPersonInfo) : TResult;

Параметры:

APersonInfo

Информация о сотруднике.


AddPersonMaster

Мастер добавления нового сотрудника.

function AddPersonMater : TResult;


Connect

Подключение к базе данных системы учета рабочего времени TimeControl.

function Connect(ALiasName : TStr20) : TResult;

Параметры:

ALiasName

Название псевдонима подключения из файла timecontrol.ini. По умолчанию в файле timecontrol.ini задан только один псевдоним dentbase.


ClearFinger

Очистка отпечатков пальцев сотруднику.

function ClearFinger(ATabNum : TStr8; AFingerNum : Integer) : TResult;

Параметры:

ATabNum | Табельный номер сотрудника.
AFingerNum | 1 - Очистка основного отпечатка 2 - Очистка дополнительного отпечатка.


DeletePerson

Удаление сотрудника из системы по табельному номеру.

function DeletePerson(ATabNum : TStr8) : TResult;

Параметры:

ATabNum

Табельный номер сотрудника.


Disconnect

Отключение от базы данных.

procedure Disconnect;


GetPersonInfo

Получение информации о сотруднике по табельному номеру

function GetPersonInfo(ATabNum : TStr8; var APersonInfo: TPersonInfo) : TResult;

Параметры:

ATabNum | Табельный номер сотрудника.
APersonInfo | Информация о сотруднике.


Login

Вход в систему пользователя.

function Login(AUserTabNum : TStr8;

AUserPassword : TStr20) : TResult;

Параметры:

AUserTabNum | Табельный номер сотрудника, для которого осуществляется вход в систему.
AUserPassword | Пароль сотрудника для входа в систему.


Logout

Отключение текущего пользователя.

procedure Logout;


RefreshDevices

Оповестить устройства об изменениях.

function RefreshDevices : TResult;


SetFinger

 Top Previous

Установка отпечатков пальцев сотруднику.

function SetFinger(ATabNum : TStr8; AFingerNum : Integer) : TResult;

Параметры:

ATabNum | Табельный номер сотрудника.
AFingerNum | 1 - Установка основного отпечатка 2 - установка дополнительного отпечатка